summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8619fcfd3adc..12c77b2aa438 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mxnet
_gitname=incubator-mxnet
pkgver=1.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="Flexible and Efficient Library for Deep Learning"
arch=('x86_64')
url="http://mxnet.io/"
@@ -11,8 +11,9 @@ license=('Apache')
depends=('hdf5' 'cblas' 'lapack' 'python-numpy' 'python-requests' 'intel-tbb')
optdepends=('cairo' 'cuda' 'cudnn' 'gtk3' 'gtkglext' 'python-graphviz' 'opencv' 'vtk' 'glew')
makedepends=(${optdepends[@]} 'git' 'cython')
-source=("git+https://github.com/apache/$_gitname#tag=$pkgver")
-md5sums=('SKIP')
+source=("git+https://github.com/apache/$_gitname#tag=$pkgver"
+ "cuda_call.patch")
+md5sums=('SKIP' '77a777e6971e568177e0ea3aeecb401c')
prepare() {
cd "$srcdir/$_gitname"
@@ -53,6 +54,9 @@ prepare() {
-e 's|mxnet/%s/.%s|mxnet_%s_%s|' \
-e 's|../3rdparty/nnvm/include|../3rdparty/tvm/nnvm/include|' \
-i python/setup.py
+
+ # https://github.com/apache/incubator-mxnet/pull/12374
+ patch -p1 < ${srcdir}/cuda_call.patch
}
build() {