summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e8dff98752a..d542576d49d0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,22 @@
# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
pkgname=mynotes
-pkgver=2.2.1
+pkgver=2.3.0
pkgrel=1
pkgdesc="Desktop post-it / sticky notes managed from system tray icon"
arch=('any')
url="https://sourceforge.net/projects/my-notes"
license=('GPL3')
-depends=('tktray' 'python-ewmh' 'gettext' 'desktop-file-utils' 'python-setuptools')
+makedepends=('python-setuptools')
+depends=('tktray' 'python-ewmh' 'python-pillow' 'gettext' 'desktop-file-utils')
optdepends=('python-tkfilebrowser: nicer file browser',
- 'zenity: nicer file browser')
+ 'zenity: nicer file browser',
+ 'tktray: GUI toolkit for the system tray icon (at least one must be installed)',
+ 'pygtk: GUI toolkit for the system tray icon (at least one must be installed)',
+ 'python-pyqt5: GUI toolkit for the system tray icon (at least one must be installed)',
+ 'python-pyqt4: GUI toolkit for the system tray icon (at least one must be installed)',
+ 'python-pyside: GUI toolkit for the system tray icon (at least one must be installed)')
source=("${pkgname}-${pkgver}.tar.gz::https://sourceforge.net/projects/my-notes/files/${pkgver}/${pkgname}-${pkgver}.tar.gz/download")
-sha512sums=('e80d7df9bace911670b69ec2f1255f96bb672c83d60a0f2eedf760bf7d80f22e2ad5cb0081258f91edb8115c4101f2ba0837c8ec3e7a4f22a912f60e0668c4f0')
+sha512sums=('7b285f6107c9ebd9e539e1f6ce1b6ac385ac539e1399debaf96d18a29ab5f7d9d6ff91a2f98bd25f559b45286de0868c50232b8383c248a587f0d82aadaf94c0')
package() {
cd "$srcdir/${pkgname}-${pkgver}"