summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c6d138924ba..26971b3beefc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,16 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=mysql-workbench-git
-pkgver=6.3.7.r107.g406ec7d
+pkgver=6.3.9.r0.g1972008
pkgrel=1
# mysql & mysql-connector-c++ from git
-_gdal_version=2.1.0
+_gdal_version=2.1.3
_boost_version=1.59.0
pkgdesc='A cross-platform, visual database design tool developed by MySQL - git checkout'
arch=('i686' 'x86_64')
url='https://www.mysql.com/products/workbench/'
license=('GPL2')
-depends=('cairo' 'ctemplate' 'desktop-file-utils' 'freetype2' 'gtkmm'
+depends=('cairo' 'ctemplate' 'desktop-file-utils' 'freetype2' 'gtkmm3'
'hicolor-icon-theme' 'libgl' 'libgnome-keyring' 'libiodbc' 'libxml2'
'libzip' 'mysql-python' 'pcre' 'python2' 'python2-cairo' 'python2-paramiko'
'python2-pexpect' 'tinyxml' 'unixodbc' 'vsqlite++')
@@ -30,17 +30,21 @@ source=('git://github.com/mysql/mysql-workbench.git'
"http://download.osgeo.org/gdal/${_gdal_version}/gdal-${_gdal_version}.tar.xz"
"https://downloads.sourceforge.net/project/boost/boost/${_boost_version}/boost_${_boost_version//./_}.tar.bz2"
'http://www.antlr3.org/download/antlr-3.4-complete.jar'
- '0001-do-not-pass-type-to-std-make_pair.patch'
'0001-mysql-workbench-no-check-for-updates.patch'
+ '0002-disable-unsupported-operating-system-warning.patch'
+ '0003-add-option-to-hide-nonstandard-server-warning.patch'
+ '0004-fix-build-for-i686.patch'
'arch_linux_profile.xml')
sha256sums=('SKIP'
'SKIP'
'SKIP'
- '568b43441955b306364fcf97fb47d4c1512ac6f2f5f76b2ec39a890d2418ee03'
+ 'b489793627e6cb8d2ff8d7737b61daf58382fe189fae4c581ddfd48c04b49005'
'727a932322d94287b62abb1bd2d41723eec4356a7728909e38adb65ca25241ca'
'9d3e866b610460664522520f73b81777b5626fb0a282a5952b9800b751550bf7'
- '9088cdcf82c1a925806d9162702e19c94fa21d89d422370df3f5700e204f5b32'
'b189e15c6b6f5a707357d9a9297f39ee3a33264fd28b44d5de6f537f851f82cf'
+ '0d65832bc5a73d4cfecef4b552bb78a30ce6020a5fabe5558dcf2ade8341b593'
+ '3c9097af599f08388c471d6fd02f40ea72e5759eaa89f731e662852a5e67feea'
+ '68295716c55e5f7b07b3ec1162b512b33a0563952a0eb4ef6fd71d852c61de11'
'2ade582ca25f6d6d748bc84a913de39b34dcaa6e621a77740fe143007f2833af')
pkgver() {
@@ -59,22 +63,26 @@ pkgver() {
}
prepare() {
- cd "${srcdir}/mysql-server/"
-
- patch -Np1 < "${srcdir}"/0001-do-not-pass-type-to-std-make_pair.patch
-
cd "${srcdir}/mysql-workbench/"
# Disable 'Help' -> 'Check for Updates'
# Updates are provided via Arch Linux packages
patch -Np1 < "${srcdir}"/0001-mysql-workbench-no-check-for-updates.patch
+ # disable unsupported operating system warning
+ patch -Np1 < "${srcdir}"/0002-disable-unsupported-operating-system-warning.patch
+
+ # add option to hide nonstandard server warning
+ patch -Np1 < "${srcdir}"/0003-add-option-to-hide-nonstandard-server-warning.patch
+
+ # fix build for i686
+ patch -Np1 < "${srcdir}"/0004-fix-build-for-i686.patch
+
# we need python 2.x
sed -i '/^FIND_PROGRAM(PYTHON_EXEC /c FIND_PROGRAM(PYTHON_EXEC "python2")' \
CMakeLists.txt
# put antlr into place
- # release tarball has the files, git still needs antlr!
install -D ${srcdir}/antlr-3.4-complete.jar ${srcdir}/linux-res/bin/antlr-3.4-complete.jar
}
@@ -116,7 +124,8 @@ build() {
--includedir=/usr/include/gdal \
--with-sqlite3 \
--with-mysql="${srcdir}/install-bundle/usr/bin/mysql_config" \
- --with-curl
+ --with-curl \
+ --without-jasper
make
make DESTDIR="${srcdir}/install-bundle/" install
@@ -127,8 +136,8 @@ build() {
-DCMAKE_CXX_FLAGS="-std=c++11" \
-DCMAKE_BUILD_TYPE=Release \
-DMySQL_CONFIG_PATH="${srcdir}/install-bundle/usr/bin/mysql_config" \
- -DMYSQLCPPCONN_LIBRARY="-L${srcdir}/install-bundle/usr/lib -lmysqlcppconn" \
- -DMYSQLCPPCONN_INCLUDE_DIR="${srcdir}/install-bundle/usr/include" \
+ -DMySQLCppConn_LIBRARY="${srcdir}/install-bundle/usr/lib/libmysqlcppconn.so" \
+ -DMySQLCppConn_INCLUDE_DIR="${srcdir}/install-bundle/usr/include" \
-DGDAL_INCLUDE_DIR="${srcdir}/install-bundle/usr/include" \
-DGDAL_LIBRARY="${srcdir}/install-bundle/usr/lib/libgdal.so" \
-DUSE_BUNDLED_MYSQLDUMP=1