summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 20 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dd679b41531..97f379a70061 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,7 @@ url="http://www.nand2tetris.org/"
license=('GPL')
depends=('java-runtime')
makedepends=('unzip')
-source=("https://doc-0k-6g-docs.googleusercontent.com/docs/securesc/ha0ro937gcuc7l7deffksulhg5h7mbp1/92bkuq5p9hkk3ahamuta2d4mqnbmvqnm/1543032000000/15832485136049799367/*/1KcFPj8KQ_QAHheFmLCqs5iqC_0NCndvs"
- n2tCPUEmulator.run
+source=(n2tCPUEmulator.run
n2tVMEmulator.run
n2tJackCompiler.run
n2tHardwareSimulator.run
@@ -21,8 +20,9 @@ source=("https://doc-0k-6g-docs.googleusercontent.com/docs/securesc/ha0ro937gcuc
n2tHardwareSimulator.desktop
n2tAssembler.desktop
)
-sha256sums=('f4ea1e104c9296f98d5b3ebd30acc283a876fedcf289f7679ad80885902bebe4'
- 'f93e4c08ed6af6a687f8d144598f998a19ac544d9fe6da05c162932d00f6a592'
+_nand2teris_source="nand2tetris.zip"
+_nand2teris_url="https://drive.google.com/file/u/1/d/1KcFPj8KQ_QAHheFmLCqs5iqC_0NCndvs/view?usp=sharing"
+sha256sums=('f93e4c08ed6af6a687f8d144598f998a19ac544d9fe6da05c162932d00f6a592'
'f05fbcd9d86e7151c2e16682792586fd51086fa4864695ff8600256c15eb83d4'
'838dda39a97694ef1635ebbb0f6aa850623e281f70ef1e699930ee72e4934361'
'38884a770a7535e35363ffffb8918a13ff83f67281c71e42b488f645608564cc'
@@ -32,6 +32,22 @@ sha256sums=('f4ea1e104c9296f98d5b3ebd30acc283a876fedcf289f7679ad80885902bebe4'
'054d1883e9eeaef754d9c4f15868d3722c08672a34a8d7dcdb242620ed22ba51'
'2cd1b2c93dd68de97b7c3d9504dc850f4b60774065a70aa8496ba82c7889dc89')
+prepare() {
+ if [[ ! -f "${_nand2teris_source}" ]]
+ then
+ echo "Please download the nand2tetris source from ${_nand2teris_url} and place in the src directory."
+ exit 1
+ fi
+
+ echo "f4ea1e104c9296f98d5b3ebd30acc283a876fedcf289f7679ad80885902bebe4 ${_nand2teris_source}" | sha256sum -c --quiet
+ if [[ ! $? -eq 0 ]]
+ then
+ echo "Integrity check failed for ${_nand2teris_source}"
+ fi
+
+ unzip ${_nand2teris_source}
+}
+
package() {
cd ${srcdir}/${pkgname}