summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0ac7748e1eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='nanonote'
+pkgver=1.3.0
+pkgrel=1
+pkgdesc='Minimalist note taking application '
+arch=('x86_64')
+url='https://github.com/agateau/nanonote'
+license=('BSD')
+depends=('hicolor-icon-theme' 'qt5-base')
+makedepends=('cmake' 'python-jinja' 'python-pyaml')
+source=("git+${url}.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${pkgname}"
+ git submodule update --init
+}
+
+build() {
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B build -S "${pkgname}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C build
+}
+
+package() {
+ make DESTDIR="${pkgdir}" PREFIX="/usr" -C build install
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}/README.md"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: