summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1f3e81f6280
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: BrainDamage
+pkgname="naspro-core"
+pkgrel=1
+pkgver=0.5.1
+pkgdesc="NASPRO core is the portable runtime library at the bottom of the NASPRO Architecture for Sound PROcessing."
+arch=('x86' 'x86_64')
+url="http://naspro.sourceforge.net/libraries.html#naspro-core"
+license=("LGPL")
+depends=()
+sha1sums=("SKIP")
+source=("http://sourceforge.net/projects/naspro/files/naspro/$pkgver/naspro-core-$pkgver.tar.bz2")
+
+
+build() {
+ cd "$srcdir/naspro-core-$pkgver"
+ #FIXME: deprecation of readdir_r, should be replaced with readdir
+ #https://sourceware.org/bugzilla/show_bug.cgi?id=19056
+ CFLAGS='-Wno-error' ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/naspro-core-$pkgver"
+ make DESTDIR="$pkgdir" install
+} \ No newline at end of file