summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 22 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ac8b93cd82b..01e6d2f296dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,31 @@
# Maintainer: Thomas Weißschuh <thomas t-8ch de>
pkgname=nbdkit
-pkgver=1.24.3
-pkgrel=3
+pkgver=1.24.4
+pkgrel=1
pkgdesc="NBD server toolkit"
arch=('i686' 'x86_64')
-url="https://github.com/libguestfs/nbdkit"
+url="https://gitlab.com/nbdkit/nbdkit/"
license=('custom: BSD')
depends=()
-optdepends=('libvirt' 'lua' 'tcl' 'perl' 'rust' 'libnbd' 'go')
+makedepends=('openssh')
+optdepends=(
+ 'lua'
+ 'tcl'
+ 'perl'
+ 'rust'
+ 'go'
+ 'python'
+ 'ocaml'
+
+ 'libnbd'
+ 'libvirt'
+ 'curl'
+ 'libguestfs'
+ 'libssh'
+ 'libtorrent-rasterbar'
+ 'libselinux'
+)
checkdepends=('qemu-headless')
validpgpkeys=('F7774FB1AD074A7E8C8767EA91738F73E1B768A0')
_dldir="${pkgver%.*}"
@@ -17,7 +34,6 @@ source=(
"http://download.libguestfs.org/nbdkit/${_dldir}-stable/nbdkit-${pkgver}.tar.gz.sig"
)
-
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
autoreconf -i
@@ -38,5 +54,5 @@ check() {
make check
}
-sha256sums=('62ecc8daaf7aa189d211ea5b56c67b611a98285b71025583905fed6736b84207'
+sha256sums=('e3368c51d3f08b0001af6a6d3751cb6177b6db0ca2f3d0ac8e1ed2eeb5d1b54d'
'SKIP')