summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc71f4b3fd29..61dd81780bd0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ depends=("aspnet-runtime" "bitcoin-daemon" "dotnet-host" "dotnet-runtime" "dotne
makedepends=("git")
checkdepends=()
optdepends=()
-provides=()
+provides=(${_pkgname_lc})
conflicts=("nbxplorer")
replaces=()
backup=()
@@ -54,13 +54,13 @@ package()
# Create the systemd service.
echo -e "[Unit]
Description=${pkgdesc}
+ Requires=bitcoind.service
After=bitcoind.service
- After=network.target
+ After=network-online.target
[Service]
Type=oneshot
ExecStart=/usr/bin/${_pkgname_lc}
- RemainAfterExit=yes
Restart=on-failure
[Install]