summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b8a41fd1ab4..06bb7cc12ee7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
# Maintainer: Michael Schubert <mschu.dev at gmail> github.com/mschubert/PKGBUILDs
# Contributor: Mick Elliot <micke at sfu dot ca>
pkgname=ncbi-toolkit
-pkgver=25.2.0
-_pkgver=${pkgver//./_}
-pkgrel=2
+pkgver=27.0.0
+pkgrel=1
pkgdesc="Applications, scripts and C++ libraries for the analysis of biological data"
arch=('i686' 'x86_64')
-url="https://ncbi.github.io/cxx-toolkit/"
+url="https://github.com/ncbi/ncbi-cxx-toolkit-public"
license=('custom')
depends=('python' 'pcre' 'sqlite' 'lzo' 'libtiff' 'giflib' 'libxpm'
'mariadb-libs' 'libpng' 'gnutls' 'libxml2' 'libxslt')
@@ -14,10 +13,12 @@ optdepends=('fltk' 'wxgtk' 'fcgi')
makedepends=('autoconf' 'cpio')
provides=('blast+-bin')
conflicts=('blast+-bin')
-source=(https://ftp.ncbi.nlm.nih.gov/toolbox/ncbi_tools++/2021/Sep_30_2021/ncbi_cxx--$_pkgver.tar.gz
- LICENSE)
-sha256sums=('9f824a92750e64e7b9be98d82b84414ab4f7e5d73392dadbb87c94ff5ccf9111'
- '78bbf3f310ff43f1b5f711e7221d51da1e6f055831bd6c6941e0650bf1261df2')
+source=($pkgname-$pkgver.tar.gz::$url/archive/refs/tags/release-$pkgver.tar.gz)
+sha256sums=('c8fb3f99c6fce4f170b381f3a7789c76a2ff1c23c094c9852e2e3de1fdc57277')
+
+prepare() {
+ sed -i "39i#include <cstdint>" ncbi-cxx-toolkit-public-release-27.0.0/include/util/impl/compile_time_bits.hpp
+}
build() {
# https://ncbi.github.io/cxx-toolkit/pages/ch_config#ch_config.UNIX
@@ -39,15 +40,14 @@ build() {
FLAGS="$FLAGS --with-64"
fi
- cd "$srcdir/ncbi_cxx--$_pkgver"
- rm -f "$srcdir"/build/inc/ncbiconf_unix.h # in case of previous build
+ cd "ncbi-cxx-toolkit-public-release-$pkgver"
+# rm -f "$srcdir"/build/inc/ncbiconf_unix.h # in case of previous build
./configure $FLAGS
make
}
package() {
- cd "$srcdir/ncbi_cxx--$_pkgver"
- install -Dm644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/license
+ cd "ncbi-cxx-toolkit-public-release-$pkgver"
make prefix="$pkgdir"/usr libdir="$pkgdir"/usr/lib install
find "$pkgdir"/usr/bin -name "*test*" -delete
}