summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71eb250b9c54..dbbd5eb9b784 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Aaron Baker <aa{last name}99{at}gmail{dt}org>
pkgname=ncbi-vdb
-pkgver=2.5.7
+pkgver=2.5.8
pkgrel=1
pkgdesc="The SRA Toolkit and SDK from NCBI is a collection of tools and libraries for using data in the INSDC Sequence Read Archives."
arch=('x86_64')
@@ -10,14 +10,11 @@ url="https://github.com/ncbi/ncbi-vdb"
depends=('libxml2' 'ngs' 'hdf5')
provides=('ncbi-vdb')
license=('custom:PublicDomain')
-source=("https://github.com/ncbi/ncbi-vdb/archive/$pkgver.tar.gz" "$pkgname.patch")
-sha256sums=('e088717270a48f070d5aeb633558e778081c70e5c42e5e621d6a5b8f3c2c5e41' '19f09b19cad2ebd4df4185022e711f9bc32898926168d234833e56d70c2d2029')
+source=("https://github.com/ncbi/ncbi-vdb/archive/$pkgver.tar.gz")
+sha256sums=('7a0ccc3434220e5288a016e4a9e24d4a1deae2a7d5de594fc94b2442172b3229')
prepare(){
cd "${pkgname}-${pkgver}"
- # ncbi build process frequently checks if we are root user which interferes
- # with makepkg use of fakeroot
- patch -p1 -i "$srcdir/$pkgname.patch"
}
build(){
@@ -50,6 +47,6 @@ package(){
# TODO without this a link from libncbi-vdb-static.a -> libncbi-vdb.a is dead because
# libncbi-vdb.a gets removed somehow??
cd "$pkgdir/usr/lib/"
- ln -sf libncbi-vdb.a.2.5.7 libncbi-vdb-static.a
- ln -sf libncbi-wvdb.a.2.5.7 libncbi-wvdb-static.a
+ ln -sf "libncbi-vdb.a.$pkgver" libncbi-vdb-static.a
+ ln -sf "libncbi-wvdb.a.$pkgver" libncbi-wvdb-static.a
}