summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe4907a26385..919fc528114d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,8 @@ license=(GPL-3)
depends=(libcap)
optdepends=('namecoin: the Namecoin node')
makedepends=(go)
+install="ncdns.install"
+backup=("etc/ncdns.conf")
source=($pkgname-$pkgver.tar.gz::https://github.com/namecoin/ncdns/archive/v${pkgver}.tar.gz
ncdns.service)
@@ -41,7 +43,9 @@ package() {
install -Dm 755 $GOPATH/bin/ncdns "$pkgdir/usr/bin/ncdns"
install -Dm 644 "$srcdir"/ncdns.service "$pkgdir/usr/lib/systemd/system/ncdns.service"
install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname" README.md _doc/ncdns.conf.example
+ # we copy from template, but user must edit the conf file before starting service
+ install -Dm 644 _doc/ncdns.conf.example "$pkgdir/etc/ncdns.conf"
}
sha512sums=('6e6d25989edbcdf963c0e4275fe164a0726c142a0acbf7fe3e74c2a18da7dcf2fbe8f0a3a5877ac7b551614ff227dd085490c9cfab6c8dce8e891badd87087a0'
- '428987be4c51c58aa3e144f22f5dcf788bd9aa807caccaa0981cc836aa0b8343062aaeef813bedfb8d94817a017922d7880341b7fdc5bb77dd52eb81f122b21d')
+ '4fca961ae7fc17fbb159dc6cfe3bf6be52b7e1423f0c04591100780a72f250cb87263e3eb736b363d2e67dbd8485018cbaa720ccaa4450bb93d220f802b4be40')