summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 949cc7603471..b9bf9d3b946a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,11 @@
pkgname=ncsa-mosaic-git
epoch=1
-pkgver=2.7b6.r30.5d3543d
+pkgver=2.7b6.r37.6b855b3
_pkgver=2.7b6
pkgrel=1
pkgdesc="One of the first graphical web browsers"
-url="https://github.com/yotann/ncsa-mosaic"
+url="https://github.com/alandipert/ncsa-mosaic"
license=('custom')
arch=('i686' 'x86_64')
depends=('openmotif' 'libjpeg' 'libpng' 'libxmu' 'libxpm' 'xorg-fonts-misc' 'xorg-fonts-100dpi'
@@ -19,7 +19,7 @@ makedepends=('git')
provides=("${pkgname%-git}" 'mosaic')
conflicts=("${pkgname%-git}" 'mosaic')
options=(!makeflags)
-source=('git+https://github.com/yotann/ncsa-mosaic.git')
+source=('git+https://github.com/alandipert/ncsa-mosaic.git')
sha256sums=('SKIP')
pkgver() {
@@ -29,14 +29,13 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- make linux
+ # https://github.com/alandipert/ncsa-mosaic/issues/14
+ make linux customflags=-fcommon
}
package() {
cd "$srcdir/${pkgname%-git}"
install -Dm755 src/Mosaic -t "$pkgdir/usr/bin"
install -Dm644 COPYRIGHT -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
- install -Dm644 desktop/Mosaic.png -t "$pkgdir/usr/share/icons"
- install -Dm644 desktop/Mosaic.desktop -t "$pkgdir/usr/share/applications"
install -Dm644 docs/resources.html -t "$pkgdir/usr/share/doc/${pkgname%-git}"
}