summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 158bdce2888f..a44676f51f62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,16 @@
pkgname=ndjbdns
pkgver=1.06
-pkgrel=1
+pkgrel=2
pkgdesc="ndjbdns is a fork of djbdns"
arch=('i686' 'x86_64')
url="http://pjp.dgplug.org/ndjbdns/"
license=('GPL2')
depends=('systemd')
-source=("http://pjp.dgplug.org/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('6996f803bb6c6fed5a02ad45690d62ad')
+source=("http://pjp.dgplug.org/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'arch-systemd-bin-directory.patch')
+sha256sums=('5ce5a7c5031f220a85fc8bca903f2d3cf484ff77e4c85e7144a0e2a5922a1127'
+ '437486cdedac54600ef5152d1ccb6fedd6b8df785b6880805b1762d70287d9c7')
build()
{
@@ -21,8 +23,12 @@ build()
echo ${_root_servers} | tr ' ' '\n' > etc/servers/dnsroots.global
fi
+ # Fix sbin directory in systemd files.
+ patch -p1 < "${srcdir}"/arch-systemd-bin-directory.patch
+
./configure \
--prefix=/usr \
+ --sbindir=/usr/bin \
--sysconfdir=/etc \
--disable-silent-rules
make