summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0d1af154ac8..8b1a910eafe8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=nemo-deja-dup-git
-_gitname=nemo-actions
pkgver=r2.f99427f
-pkgrel=4
+pkgrel=5
pkgdesc="Déjà Dup Actions for Nemo File Manager"
arch=('any')
-url="https://github.com/erickj/$_gitname"
-license=('GPL')
+url="https://github.com/erickj/nemo-actions"
+license=('unknown')
depends=('nemo' 'deja-dup')
-source=("git+https://github.com/erickj/$_gitname.git")
-md5sums=('SKIP')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/erickj/nemo-actions.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_gitname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd nemo-actions
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$srcdir/$_gitname"
- install -Dm755 deja-dup_restore-missing.nemo_action "$pkgdir/usr/share/nemo/actions/deja-dup_restore-missing.nemo_action"
- install -Dm755 deja-dup_revert.nemo_action "$pkgdir/usr/share/nemo/actions/deja-dup_revert.nemo_action"
+ cd nemo-actions
+ install -Dm644 *.nemo_action -t "$pkgdir/usr/share/nemo/actions/"
}