summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 14 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f2be50de09a..5e1a2f73422c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=nemo-ext-git-git
pkgver=1.3.r16.g5389549
-pkgrel=5
+pkgrel=6
pkgdesc="Nemo extension to add important information about the current git directory"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/bilelmoussaoui/nautilus-git"
-license=('GPL3')
-depends=('git' 'gtk3' 'nemo-python')
+license=('GPL-3.0-or-later')
+depends=('git' 'gtk3' 'gtksourceview3' 'nemo-python')
makedepends=('meson')
-provides=("${pkgname%-git}=1.3" 'nautilus-git=1.3')
-conflicts=("${pkgname%-git}-1.3" 'nautilus-git=1.3' 'nemo-folder-icons')
+provides=("${pkgname%-git}" 'nautilus-git')
+conflicts=("${pkgname%-git}" 'nautilus-git' 'nemo-folder-icons')
# See https://github.com/bilelmoussaoui/nautilus-folder-icons/issues/34
source=("${pkgname%-git}::git+https://github.com/bilelmoussaoui/nautilus-git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')"
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
# Disable post_install, not available in meson-options
sed -i '37,38d' meson.build
+
+ # Use Python 3
+ find . -type f -exec sed -i 's|python2|python|g' {} \;
}
build() {
@@ -31,11 +34,6 @@ build() {
meson compile -C build
}
-# No tests defined
-#check() {
-# meson test -C build --print-errorlogs
-#}
-
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}