summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c139f7b3c5d9..03178bde8991 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Marcel Campello Ferreira <tucho.tijucano@gmail.com>
pkgname=neo4j
-pkgver=2.0.2
-pkgrel=1
+pkgver=2.0.3
+pkgrel=2
pkgdesc="A fully transactional graph database implemented in Java"
arch=(any)
url="http://neo4j.org/"
license=(GPL)
-depends=(bash lsof java-runtime)
+makedepends=(patch)
+depends=(bash lsof java-runtime-headless)
backup=(etc/neo4j/custom-logback.xml
etc/neo4j/logging.properties
etc/neo4j/neo4j-http-logging.xml
@@ -21,11 +22,11 @@ source=(http://dist.neo4j.org/neo4j-community-$pkgver-unix.tar.gz
neo4j.install
neo4j.service
neo4j-tmpfile.conf)
-sha256sums=(e137fd4f259c584f4e3ec6ed446031d80e6099874a0b5dec9440bfbb81fdd5c0
+sha256sums=(f7698c0f479bdffc8713d299314a322305cfa094859a88a99b50e8cf3df099e9
870d0fe93a07053df8edcee32c5638414336116a2a26531fa689e849032fdf9e
47f7648c0d609d363ae8e4ad5317a7f37f7625c4ac05a356d2d41a9bfbde495a
- 7cec057ea41df6333389ef5d9654fa7769ea141dbe5da5bf1b526c6de292e22f
- 27e044354f10cb4c844b827442850326d900bc40e01443dbc0cd446bd057af27
+ b86e71e80ad7c2e10a095dfd42296c117ffafa10ee1cc923e1072f6d64ac9dfa
+ 9b6438b75b88a89e89751996942c453fb60c6e8b0bd5aa432bbefddc753362d8
e9ecbf86072ca92129ab1889b5f91e2494b86e84248bd15a37681a3997892d7d)
prepare() {
@@ -69,10 +70,6 @@ package() {
install -dm755 $pkgdir/var/lib/neo4j/data
install -dm755 $pkgdir/var/log/neo4j
- # Documentation files
- install -dm 755 $pkgdir/usr/share/doc/neo4j
- cp -r doc/* $pkgdir/usr/share/doc/neo4j
-
# License files
install -dm755 $pkgdir/usr/share/licenses/neo4j
cp LICENSE.txt LICENSES.txt NOTICE.txt $pkgdir/usr/share/licenses/neo4j