summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa8d132a4160
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dylan Araps <dyl@tfwno.gf>
+pkgname=fetch-git
+_pkgname=fetch
+pkgver=0.2.1.r88.gea3508f
+pkgrel=1
+pkgdesc="CLI script to show your system's info and display an image using w3m."
+arch=('any')
+url="https://github.com/dylanaraps/fetch"
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=('bash' 'ncurses')
+optdepends=(
+ 'w3m: Display Images'
+ 'imagemagick: Image cropping / Thumbnail creation'
+ 'feh: Wallpaper Displau'
+ 'mpc: Current Song Displau'
+ 'xorg-xdpyinfo: Resolution Detection'
+ 'wmctrl: Accurate window manager detection'
+)
+makedepends=('git')
+source=("$pkgname::git+https://github.com/dylanaraps/fetch.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long | sed -r -e 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 "fetch" "$pkgdir/usr/bin/fetch"
+}