summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b35c3113c3fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Tim Harding <tim@timharding.co>
+
+pkgname='neophyte-bin'
+pkgver='0.2.4'
+pkgrel=1
+pkgdesc="A WebGPU-rendered Neovim GUI"
+arch=('x86_64')
+url="https://github.com/tim-harding/neophyte"
+license=('MIT')
+provides=("neophyte=$pkgver")
+conflicts=('neophyte' 'neophyte-git')
+source=(
+ "neophyte::$url/releases/download/$pkgver/$pkgname-linux"
+ "README.md::$url"
+)
+sha256sums=('SKIP') # TODO: Add checksums
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim: ts=4 sts=4 sw=4 et