summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62cbeb3976a6..dd569d12a39c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,26 @@
pkgname=neopo-git
_gitname="neopo"
-pkgver=r326.9a9b1d1
+pkgver=r334.970c5fd
pkgrel=1
pkgdesc="A lightweight solution for local Particle development."
-arch=('x86_64' 'aarch64')
+arch=("x86_64" "aarch64")
url="https://github.com/nrobinson2000/neopo"
-license=('custom')
-provides=('neopo')
-source=('git+https://github.com/nrobinson2000/neopo.git'
- 'git+https://github.com/nrobinson2000/particle-cli-completion')
-md5sums=('SKIP' 'SKIP')
-makedepends=('python-setuptools')
-depends=('python' 'vim' 'git' 'perl-archive-zip' 'libusb' 'jq')
+license=("custom")
+provides=("neopo")
+source=("git+https://github.com/nrobinson2000/neopo.git"
+ "git+https://github.com/nrobinson2000/particle-cli-completion")
+md5sums=("SKIP"
+ "SKIP")
+makedepends=("python-setuptools")
+depends=("python" "vim" "git" "perl-archive-zip" "libusb" "jq")
-optdepends=('visual-studio-code-bin: Particle Workbench IDE'
- 'bash-completion: Bash completion (neopo/particle)')
-optdepends_x86_64=('lib32-glibc: gcc-arm 5.3.1 support')
-optdepends_aarch64=('dfu-util: flash devices with DFU'
- 'nodejs: support for particle-cli'
- 'openocd-git: support for debugging')
+optdepends=("visual-studio-code-bin: Particle Workbench IDE"
+ "bash-completion: Bash completion")
+optdepends_x86_64=("lib32-glibc: gcc-arm 5.3.1 support")
+optdepends_aarch64=("dfu-util: flash devices with DFU"
+ "nodejs: support for particle-cli"
+ "openocd-git: support for debugging")
pkgver() {
cd "$_gitname"