summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65ec08ea2520
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=neovim-lion-opt-git
+pkgver=56.75306ac
+_pkgname=lion
+pkgrel=1
+pkgdesc='A simple alignment operator for (neo)vim.'
+arch=('any')
+url="https://github.com/tommcdo/vim-${_pkgname}"
+license=('custom:vim')
+depends=('neovim')
+makedepends=('git')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+
+ cd "${srcdir}/vim-${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+
+}
+
+package() {
+
+ cd "${srcdir}/vim-${_pkgname}"
+
+ local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}/"
+
+ install -dvm755 "${pkgdir}/${_installpath}"
+
+ cp -rvt "${pkgdir}/${_installpath}" doc plugin
+
+}