summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 14 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb8358dca330..8d5791dfd3bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
-# Maintainer: Tomas Storck <storcktomas@gmail.com>
+# Maintainer: Doug Newgard <scimmia at archlinux dot info>
+# Contributor: Tomas Storck <storcktomas@gmail.com>
# Contributor: Tom Richards <tom@tomrichards.net>
+
pkgname=neovim-symlinks
-pkgver=1.0.1
-pkgrel=3
-pkgdesc="System-wide: Runs neovim if vi or vim is invoked."
+pkgver=2
+pkgrel=1
+pkgdesc='Runs neovim if vi or vim is called'
arch=('any')
-license=('MIT')
-depends=('neovim')
+depends=('neovim' 'sh')
provides=('vim' 'vi')
conflicts=('vim' 'vi' 'vi-vim-symlink')
-source=('vimdiff')
-md5sums=('8ca45b6b93e6dab571f542ef262093e4')
-sha256sums=()
package() {
- install -dm755 "$pkgdir/usr/bin"
+ install -dm755 "$pkgdir/usr/bin/"
- # vim --> nvim
- _link_names=(edit ex rview rvim vedit vi view vim)
- for _link in "${_link_names[@]}";
- do
- ln -s nvim "$pkgdir/usr/bin/$_link"
- done
+ for _link in edit ex rview rvim vedit vi view vim; do
+ ln -s nvim "$pkgdir/usr/bin/$_link"
+ done
- # vimdiff --> nvim -d
- install -Dm755 "$srcdir/vimdiff" "$pkgdir/usr/bin/vimdiff"
+ # vimdiff --> nvim -d
+ echo -e '#!/bin/sh\nexec vim -d "$@"' > "$pkgdir/usr/bin/vimdiff"
+ chmod 755 "$pkgdir/usr/bin/vimdiff"
}
-