summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bed37a2011ec..357f5d01ea57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
-# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
-# Maintainer: aimileus < me at aimileus dot nl >
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: aimileus < me at aimileus dot nl >
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Tiago Pierezan Camargo <tcamargo@gmail.com>
# Contributor: robb_force <robb_force@holybuffalo.net>
pkgname=nestopia
-pkgver=1.49
+pkgver=1.50
pkgrel=1
pkgdesc='An NES emulator featuring cycle exact emulation, a ridiculous number of mappers, and lots of custom sound chips.'
url='http://0ldsk00l.ca/nestopia/'
license=('GPL')
arch=('x86_64')
-depends=('sdl2' 'gtk3' 'libarchive' 'libao')
-makedepends=('unzip' 'mesa' 'xdg-utils' 'git' 'autoconf-archive')
-source=("git+https://github.com/rdanbrook/nestopia.git#tag=$pkgver")
-sha256sums=('SKIP')
+depends=('sdl2' 'gtk3' 'libarchive')
+makedepends=('unzip' 'mesa' 'xdg-utils' 'autoconf-archive')
+source=($pkgname-$pkgver.tar.gz::"https://github.com/0ldsk00l/nestopia/archive/$pkgver.tar.gz")
+sha256sums=('f0274f8b033852007c67237897c69725b811c0df8a6d0120f39c23e990662aae')
build() {
- cd "$pkgname"
- autoreconf -vif
- ./configure --prefix=/usr
+ cd $pkgname-$pkgver
+
+ autoreconf -fi
+ ./configure --prefix=/usr --enable-gui
make
}
package() {
- cd "$pkgname"
- make install DESTDIR="$pkgdir"
+ make -C $pkgname-$pkgver install DESTDIR="$pkgdir"
}