summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 18 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74aefd7fc58d..1883cb1ca52b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,39 +3,42 @@
pkgname=netease-musicbox
_gitname=musicbox
-pkgver=0.2.5.4
+_pyname=NetEase-MusicBox
+pkgver=0.3.1
pkgrel=2
pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
arch=(any)
url="https://github.com/darknessomi/musicbox"
-depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future' 'python-requests-cache')
-makedepends=('python-setuptools')
+depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future'
+ 'python-fuzzywuzzy' 'python-requests-cache' 'python-importlib-metadata')
+makedepends=('python-setuptools' 'python-poetry')
optdepends=('aria2: music caching'
'libnotify: notifications'
'qt5-base: lyrics support'
+ 'python-qtpy: lyrics support'
'python-pyqt5: lyrics support'
- 'python-dbus: lyrics support')
-provides=('netease-musicbox')
-conflicts=('netease-musicbox')
-install=$pkgname.install
+ 'python-dbus: lyrics support'
+ 'python-levenshtein: fuzzy search support')
+provides=('musicbox')
+conflicts=('netease-musicbox-git')
license=('MIT')
source=("musicbox-$pkgver.tar.gz::https://github.com/darknessomi/musicbox/archive/${pkgver}.tar.gz"
- "LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE.txt"
- "0001-Replace_pyqt4_to_pyqt5_as_depends.patch")
+ "LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE")
-sha256sums=('4fdfd9061dfdec181736b56166a11bfe27ae9c4011f9c266b57fdfbca232afa3'
- '50efc98142cfffe413d73c87c91f2687dfb774217af923f03dfdc8426c9d9552'
- '4ce77308982339ef8f90ac34e3d9e0f1b2894d4d36a09a3071919bbc39b6dde5')
+sha256sums=('b7f984b0462b553ebc8fccb414783b07936efa49fdd1822d2c79a4c8aa624f4e'
+ '40aaf7aea7939284b07c487929472fa9cc5a842ff5f0c1e474ac93e6de7aa64e')
-prepare() {
+build() {
cd "${srcdir}/musicbox-${pkgver}"
- patch -Np1 -i "${srcdir}/0001-Replace_pyqt4_to_pyqt5_as_depends.patch"
+ poetry build -f sdist
+ tar xvf "./dist/${_pyname}-${pkgver}.tar.gz"
}
package() {
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "${srcdir}/musicbox-${pkgver}"
+
+ cd "${srcdir}/musicbox-${pkgver}"/${_pyname}-${pkgver}
python setup.py install --root="${pkgdir}/" --optimize=1
}
# vim:set ts=4 sw=4 et: