summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0dfa904c137a..d6f655b1ec66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,35 +4,30 @@
pkgname=netease-musicbox
_gitname=musicbox
_pyname=NetEase-MusicBox
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
arch=(any)
url="https://github.com/darknessomi/musicbox"
depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future'
- 'python-fuzzywuzzy' 'python-requests-cache' 'python-levenshtein')
+ 'python-fuzzywuzzy' 'python-requests-cache' )
makedepends=('python-setuptools' 'python-poetry')
optdepends=('aria2: music caching'
'libnotify: notifications'
'qt5-base: lyrics support'
+ 'python-qtpy: lyrics support'
'python-pyqt5: lyrics support'
- 'python-dbus: lyrics support')
+ 'python-dbus: lyrics support'
+ 'python-levenshtein: fuzzy search support')
provides=('musicbox')
conflicts=('netease-musicbox-git')
license=('MIT')
source=("musicbox-$pkgver.tar.gz::https://github.com/darknessomi/musicbox/archive/${pkgver}.tar.gz"
- "LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE"
- "0001-Replace_pyqt4_to_pyqt5_as_depends.patch")
+ "LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE")
-sha256sums=('fc9a6e2947d491b08123ef6b826772c9d6539ce6aaa984e5f737264344edfd42'
- '40aaf7aea7939284b07c487929472fa9cc5a842ff5f0c1e474ac93e6de7aa64e'
- 'b7e69d2fe2886ed9e66769e759add027a527089cf2770f8b7377a806e9079a03')
-
-prepare() {
- cd "${srcdir}/musicbox-${pkgver}"
- patch -Np1 -i "${srcdir}/0001-Replace_pyqt4_to_pyqt5_as_depends.patch"
-}
+sha256sums=('b7f984b0462b553ebc8fccb414783b07936efa49fdd1822d2c79a4c8aa624f4e'
+ '40aaf7aea7939284b07c487929472fa9cc5a842ff5f0c1e474ac93e6de7aa64e')
build() {
cd "${srcdir}/musicbox-${pkgver}"