summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD73
1 files changed, 29 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c5d9f1f40cd..ec5113e4ae2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,50 @@
# Maintainer: Jiachen Yang <farseerfc@gmail.com>
-# Contributor: Ariel AxionL <axionl@aosc.io>
+# Maintainer: Ariel AxionL <axiionl@aosc.io>
-pkgbase=netease-musicbox-git
-pkgname=(netease-musicbox-git netease-musicbox-py2-git)
+pkgname=netease-musicbox-git
_gitname=musicbox
-pkgver=r567.4820cb0
+pkgver=r577.cdcbd50
pkgrel=1
pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
arch=(any)
url="https://github.com/darknessomi/musicbox"
-depends=()
+depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future')
+makedepends=('python-setuptools' 'git')
optdepends=('aria2: music caching'
- 'libnotify: notifications')
-license=('MIT')
-_py2depends=('python2' 'python2-requests' 'python2-setuptools' 'mpg123'
- 'python2-future' 'python2-pycryptodomex' 'python2-requests-cache')
-_py3depends=('python' 'python-requests' 'python-setuptools' 'mpg123'
- 'python-future' 'python-pycryptodomex' 'python-requests-cache')
-makedepends=('git'
- ${_py2depends[@]}
- ${_py3depends[@]}
-) # both python and python2 depends goes to makedepends
-options=(!emptydirs)
+ 'libnotify: notifications'
+ 'qt5-base: lyrics support'
+ 'python-pyqt5: lyrics support'
+ 'python-dbus: lyrics support')
provides=('netease-musicbox')
conflicts=('netease-musicbox')
-install=$pkgname.install
+install=${pkgname}.install
+license=('MIT')
-source=("git+https://github.com/darknessomi/musicbox")
+source=("${_gitname}::git+https://github.com/darknessomi/musicbox"
+ "LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE.txt"
+ "0001-Remove_python_requests_cache_as_depends.patch"
+ "0002-Replace_pyqt4_to_pyqt5_as_depends.patch")
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ '50efc98142cfffe413d73c87c91f2687dfb774217af923f03dfdc8426c9d9552'
+ '0faefb24ad158814cda0a5fd2262c2308182d22791587382d68da09922338052'
+ 'f9c95f8441f43fc13c2cadb1f62b6e33658474f7671d11b3f0a66fe322e0a9e9')
pkgver() {
- cd $_gitname
+ cd "${srcdir}/${_gitname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package_netease-musicbox-py2-git() {
- replace=("netease-musicbox-git<=r515.7dfd3fe-1")
- depends=(${_py2depends[@]})
- optdepends=('aria2: music caching'
- 'python2-keybinder2: global keybindings'
- 'libnotify: notifications'
- 'python2-pyqt4: lyrics support'
- 'python2-dbus: lyrics support'
- )
- cd "$srcdir/$_gitname"
- python2 setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m755 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+prepare() {
+ cd "${srcdir}/${_gitname}"
+ git apply "${srcdir}/0001-Remove_python_requests_cache_as_depends.patch"
+ git apply "${srcdir}/0002-Replace_pyqt4_to_pyqt5_as_depends.patch"
}
-package_netease-musicbox-git() {
- depends=(${_py3depends[@]})
- optdepends=('aria2: music caching'
- 'libnotify: notifications'
- 'python-pyqt4: lyrics support'
- 'python-dbus: lyrics support'
- )
- cd "$srcdir/$_gitname"
- python setup.py install --root="$pkgdir/" --optimize=1
+package() {
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/${_gitname}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m755 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
}
-# vim:set ts=2 sw=2 et:
+# vim:set ts=2 sw=2 et: \ No newline at end of file