summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6b149337c96..d2ad475b0468 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=netlink-notify-git
-pkgver=0.7.5.r0.ga29c91a
+pkgver=0.8.1.r2.gebe67ba
pkgrel=1
pkgdesc="Notify about netlink changes - git checkout"
arch=('i686' 'x86_64')
url="https://github.com/eworm-de/netlink-notify"
depends=('libsystemd' 'libnotify')
-makedepends=('git' 'systemd' 'imagemagick' 'markdown')
+makedepends=('git' 'systemd' 'imagemagick' 'discount')
provides=('netlink-notify')
conflicts=('netlink-notify')
license=('GPL')
-source=('git://github.com/eworm-de/netlink-notify.git')
+source=('git+https://github.com/eworm-de/netlink-notify.git')
sha256sums=('SKIP')
pkgver() {
@@ -21,11 +21,11 @@ pkgver() {
printf '%s.r%s.g%s' \
"$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
"$(git rev-list --count ${GITTAG}..)" \
- "$(git log -1 --format='%h')"
+ "$(git rev-parse --short HEAD)"
else
printf '0.r%s.g%s' \
"$(git rev-list --count master)" \
- "$(git log -1 --format='%h')"
+ "$(git rev-parse --short HEAD)"
fi
}