summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c7e5fb18c0a..0c2660eaee6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=network-ups-tools
pkgver=2.7.3
-pkgrel=2
+pkgrel=3
pkgdesc="NUT is a collection of programs for monitoring and administering UPS hardware"
arch=('i686' 'x86_64')
url="http://www.networkupstools.org/"
@@ -15,9 +15,17 @@ depends=('openssl' 'libusb-compat' 'libltdl' 'neon' 'net-snmp')
makedepends=('asciidoc')
backup=(etc/ups/{ups.conf,upsd.conf,upsd.users,upsmon.conf,upssched.conf})
install=nut.install
-source=("http://www.networkupstools.org/source/2.7/nut-${pkgver}.tar.gz")
+source=("http://www.networkupstools.org/source/2.7/nut-${pkgver}.tar.gz"
+ "https://github.com/networkupstools/nut/commit/c98fab9f5dec993aa9f5e0a3e79de53ae9ecd32b.patch")
options=('!emptydirs' '!libtool')
-sha256sums=('ff44d95d06a51559a0a018eef7f8d17911c1002b6352a7d7580ff75acb12126b')
+sha256sums=('ff44d95d06a51559a0a018eef7f8d17911c1002b6352a7d7580ff75acb12126b'
+ '2227fedd3ad1c392d1a359f456b7d6889b4d0ca8e0e4df5ce6930c1f24e99a1f')
+
+prepare() {
+ cd "$srcdir/nut-$pkgver"
+ # https://github.com/networkupstools/nut/issues/200
+ patch -p1 -i "$srcdir/c98fab9f5dec993aa9f5e0a3e79de53ae9ecd32b.patch"
+}
build() {
cd "$srcdir/nut-$pkgver"