summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ed85d715f16..fcc21ce16151 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Helder Bertoldo <helder.bertoldo@gmail.com>
+# Contributor:
-gitname=Newaita
-author=cbrnix
+_gitname=Newaita
+_author=cbrnix
pkgname=newaita-icons-git
-pkgver=r218.2a95a1cf
+pkgver=latest
pkgrel=1
pkgdesc="Newaita icon theme is a Linux icon theme combining old style and color of material design. If you urgently needed any icon, please write in the comments on the page https://store.kde.org/p/1243493/ If you want support me Paypal: ghostdmn2@gmail.com"
arch=('i686' 'x86_64')
-url="https://github.com/${author}/${gitname}"
+url="https://github.com/${_author}/${_gitname}"
license=('CC BY-NC-SA 3.0')
makedepends=('git')
options=('!strip')
@@ -17,7 +18,7 @@ source=("git+${url}.git")
sha256sums=('SKIP')
pkgver(){
- cd "${gitname}"
+ cd "${_gitname}"
( set -o pipefail
git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -26,7 +27,7 @@ pkgver(){
package() {
install -d ${pkgdir}/usr/share/icons
- cp -r ${gitname}/* ${pkgdir}/usr/share/icons/
+ cp -r ${_gitname}/* ${pkgdir}/usr/share/icons/
find ${pkgdir}/usr -type f -exec chmod 644 {} \;
find ${pkgdir}/usr -type d -exec chmod 755 {} \;
rm -rf "$pkgdir/usr/share/icons/README.md"