summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD121
1 files changed, 88 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd583a3b3e1e..a3863ea66a21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,108 @@
-# Maintainer: Michael Riegert <michael at eowyn net>
+# Maintainer:
+# Contributor: Michael Riegert <michael at eowyn net>
# Contributor: Danilo Kuehn <dk at nogo-software dot de>
-pkgname=nextcloud-client-git
-_name=${pkgname/\-git/}
-pkgver=3.4.0.rc2.r181.gc69cecced
+## useful links
+# https://nextcloud.com/
+# https://github.com/nextcloud/desktop
+
+# basic info
+_pkgname="nextcloud-client"
+pkgname="$_pkgname-git"
+pkgver=3.13.0.r185.gf15810a
pkgrel=1
pkgdesc="Nextloud client for linux"
+url="https://github.com/nextcloud/desktop"
+license=('GPL-2.0-or-later')
arch=('i686' 'x86_64')
-url="https://nextcloud.com/"
-license=('GPL2')
-depends=(openssl sqlite qtkeychain qt5-svg qt5-webengine xdg-utils qt5-webkit
- libcloudproviders qt5-graphicaleffects qt5-quickcontrols2 qt5-websockets inkscape)
-makedepends=(doxygen extra-cmake-modules python-sphinx qt5-tools git cmocka)
+
+depends=(
+ karchive
+ kguiaddons
+ kio
+ libcloudproviders
+ openssl
+ qt6-5compat
+ qt6-base
+ qt6-declarative
+ qt6-svg
+ qt6-webengine
+ qt6-websockets
+ qtkeychain-qt6
+ sqlite
+)
+makedepends=(
+ cmocka
+ doxygen
+ extra-cmake-modules
+ git
+ python-sphinx
+ qt6-tools
+)
optdepends=(
- 'kio: integration with Dolphin'
- 'nemo-python: integration with Nemo'
- 'python-nautilus: integration with Nautilus'
- 'python-caja: integration with Caja'
+ 'nemo-python: integration with Nemo'
+ 'python-caja: integration with Caja'
+ 'python-nautilus: integration with Nautilus'
)
-provides=('mirall' 'mirall-git' 'owncloud-client' 'nextcloud-client')
-conflicts=('mirall-git' 'owncloud-client' 'owncloud-client-ngs' 'nextcloud-client' 'owncloud-client-git')
+
+provides=('owncloud-client' 'nextcloud-client')
+conflicts=('owncloud-client' 'nextcloud-client')
+
backup=('etc/Nextcloud/sync-exclude.lst')
-source=("${_name}::git+https://github.com/nextcloud/desktop.git")
-sha256sums=('SKIP')
+
+_pkgsrc="$_pkgname"
+source=(
+ "$_pkgsrc"::"git+https://github.com/nextcloud/desktop.git"
+ 'dschmidt.libcrashreporter-qt'::'git+https://github.com/dschmidt/libcrashreporter-qt.git'
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
- cd ${srcdir}/${_name}
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_pkgsrc"
+ local _tag=$(git tag | grep -Ev '[a-z]{2}' | sort -rV | head -1)
+ local _ver="${_tag#v}"
+ local _rev=$(git rev-list --count --cherry-pick $_tag...HEAD)
+ local _hash=$(git rev-parse --short=7 HEAD)
+
+ printf '%s.r%s.g%s' "${_ver:?}" "${_rev:?}" "${_hash:?}"
}
prepare() {
- cd ${srcdir}/${_name}
- if [[ -n "${_version}" ]]; then
- git checkout "v${_version}"
- fi
- git submodule update --init --recursive
- mkdir -p build
+ _submodule_update() {
+ local _module
+ for _module in "${_submodules[@]}" ; do
+ git submodule init "${_module##*::}"
+ git submodule set-url "${_module##*::}" "$srcdir/${_module%::*}"
+ git -c protocol.file.allow=always submodule update "${_module##*::}"
+ done
+ }
+
+ cd "$srcdir/$_pkgsrc"
+ local _submodules=(
+ 'dschmidt.libcrashreporter-qt'::'src/3rdparty/libcrashreporter-qt'
+ )
+ _submodule_update
}
build() {
- cd ${srcdir}/${_name}/build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE="Release" \
- -DWITH_DOC=FALSE
- make
+ local _cmake_options=(
+ -B build
+ -S "$_pkgsrc"
+ -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ -DCMAKE_INSTALL_LIBDIR='lib'
+ -DWITH_DOC=FALSE
+ -DBUILD_TESTING=OFF
+ -Wno-dev
+ )
+
+ cmake "${_cmake_options[@]}"
+ cmake --build build
}
package() {
- cd ${srcdir}/${_name}/build
- make DESTDIR=${pkgdir} install
+ DESTDIR="$pkgdir" cmake --install build
}