summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f9569e1b4a8..002791f92e48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
-# Maintainer: mh00h <matt.halbert@gmail.com>
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: mh00h <matt.halbert@gmail.com>
+
pkgname=nextflow
-pkgver=20.01.0
+pkgver=20.04.1
pkgrel=1
pkgdesc="A DSL for data-driven computational pipelines"
install=nextflow.install
arch=('any')
-url="https://www.nextflow.io"
+url='https://www.nextflow.io'
license=('Apache')
depends=('java-runtime>=8')
-source=("https://github.com/nextflow-io/nextflow/releases/download/v${pkgver}/nextflow")
-sha512sums=('092ec1ef952f5d5d938e591cbcf30dc2e5bc391b13679153d2fdb897a78a53ffa6e37971a4e9b1e103efeef69076eb3dacd16949934bc882f029307f59d97c1d')
+source=("${pkgname}-${pkgver}::https://github.com/nextflow-io/nextflow/releases/download/v${pkgver}/nextflow")
+sha256sums=('b46833ad75b9b7db72668235b53d5c295a9ab02b50d36506bbbe53f383239bde')
package() {
- install -D -m755 "${srcdir}/nextflow" "${pkgdir}/usr/bin/nextflow"
-}
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}" "${pkgdir}/usr/bin/nextflow"
+} \ No newline at end of file