summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a1a7e5bd88e..71670645a53a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+# Maintainer: Rene Hollander <mail@renehollander.at>
+# Contributor: Sefa Eyeoglu <contact@scrumplex.net>
_pkgname=nfancurve
pkgname=${_pkgname}
-pkgver=018
+pkgver=019
pkgrel=1
pkgdesc="A small and lightweight Bash script for using a custom fan curve in Linux for NVIDIA GPUs"
arch=("any")
@@ -14,14 +15,16 @@ conflicts=("${_pkgname}-git")
install=${_pkgname}.install
source=("${_pkgname}-${pkgver}::https://github.com/nan0s7/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('2d04a1313c00d4f691f24f55e0681ef02c49bd346257efa6f5c194483f0ab7611bc533b5b42c8364ca8a6be0804bcb725c8f384f5069dc4b547279df785225ec')
+sha512sums=('17f792781cafaaed19de147ecea7e7ba857650d45a7a061b5982b3a2133c1d1f858630c7bd001a3c1dd7e4e052492e3b42cdc852e22c0d56904a07755b6d45a1')
package() {
cd "${_pkgname}-${pkgver}"
install -Dm755 "temp.sh" "$pkgdir/usr/bin/nfancurve"
- install -Dm644 "config" "$pkgdir/usr/share/doc/${_pkgname}/config.example"
+ install -Dm644 "config" "$pkgdir/etc/nfancurve.conf"
+ sed -i "s/NFANCURVE_PATH\/temp.sh/\/usr\/bin\/nfancurve -c \/etc\/nfancurve.conf/" nfancurve.service
+ install -Dm644 "nfancurve.service" "$pkgdir/usr/lib/systemd/user/nfancurve.service"
install -Dm644 "README.md" "$pkgdir/usr/share/doc/${_pkgname}/README.md"
install -Dm644 "USAGE.md" "$pkgdir/usr/share/doc/${_pkgname}/USAGE.md"