summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 22 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf85772610a8..f56655745043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,32 @@
-pkgname='nfetch-git'
+# Maintainer:
+# Contributor: Fabio 'Lolix' Loli <lolix@disroot.org>
+# Contributor: Luke <Infinitybeond1@protonmail.com>
+
+pkgname=nfetch-git
pkgdesc="A minimal linux fetch utility written in nim"
-pkgver=2.61
-pkgrel=0
-arch=('x86_64')
+pkgver=2.r19.g2655d63
+pkgrel=1
+arch=(x86_64)
url="https://github.com/Infinitybeond1/nfetch-src"
-license=('GPL3')
-source=("git+https://github.com/Infinitybeond1/nfetch-src")
-makedepends=('nim' 'nimble')
-conflicts=('nfetch-bin')
+license=(GPL3)
+makedepends=(nim nimble git)
+provides=(nfetch)
+conflicts=(nfetch)
+source=("git+https://github.com/Infinitybeond1/nfetch-src.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "nfetch-src"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
- cd nfetch-src
+ cd "nfetch-src"
nimble build
}
package() {
- cd nfetch-src
- sudo install nfetch "/usr/local/bin"
+ cd "nfetch-src"
+ install -D nfetch -t "${pkgdir}/usr/bin/"
+ install -D config.ini -t "${pkgdir}/usr/share/doc/nfetch"
}