summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 3 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05032dd30cbf..74fda6e56a24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,22 @@
pkgname=nginx-mainline-mod-auth_pam
pkgver=1.5.3
-pkgrel=1
-
+pkgrel=2
_modname=ngx_http_auth_pam_module
-
pkgdesc='Nginx mainline module to use PAM for simple http authentication'
arch=('i686' 'x86_64')
depends=('nginx-mainline' 'pam')
makedepends=('nginx-mainline-src')
url="https://github.com/sto/ngx_http_auth_pam_module"
license=('BSD')
-
-source=(
- https://github.com/sto/$_modname/archive/v$pkgver/$_modname-$pkgver.tar.gz
- $_modname-critlog.patch::https://patch-diff.githubusercontent.com/raw/sto/ngx_http_auth_pam_module/pull/11.patch
-)
-
-sha256sums=('882018fea8d6955ab3fe294aafa8ebb1fdff4eac313c29583fef02c6de76fae7'
- '1a59787672cf9c6768cb77c31f19a870eaf556c7b28c8c22a22cf8a7013b93af')
+source=(https://github.com/sto/$_modname/archive/v$pkgver/$_modname-$pkgver.tar.gz)
+sha256sums=('882018fea8d6955ab3fe294aafa8ebb1fdff4eac313c29583fef02c6de76fae7')
prepare() {
mkdir -p build
cd build
ln -sf /usr/src/nginx/auto
ln -sf /usr/src/nginx/src
-
- cd "$srcdir"/$_modname-$pkgver
- patch -p1 -i "$srcdir"/$_modname-critlog.patch
}
build() {