summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b227cf6da95..dcc0ceb44cc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=nginx-mainline-mod-lua
-pkgver=0.10.11
+pkgver=0.10.12rc2
pkgrel=1
_modname="${pkgname#nginx-mainline-mod-}"
-_nginxver=1.13.7
+_nginxver=1.13.10
pkgdesc='Lua script engine module for mainline nginx'
arch=('i686' 'x86_64')
@@ -16,17 +16,11 @@ license=('BSD')
source=(
https://nginx.org/download/nginx-$_nginxver.tar.gz
https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz
- openssl-1.1.patch
)
-sha256sums=('beb732bc7da80948c43fd0bf94940a21a21b1c1ddfba0bd99a4b88e026220f5c'
- 'c0fb91fcfd1c6e7dec34ca64826ef81ffebafdef6174d254467636f380566626'
- 'de8975aa6dafa9c84d4d639716f17876f39258d07e8294ff22d95005d887fb3b')
+sha256sums=('336182104d90be3c40c874f7f06f87dbb357da1dc74ea573ad081a0f29a94885'
+ '18edf2d18fa331265c36516a4a19ba75d26f46eafcc5e0c2d9aa6c237e8bc110')
-prepare() {
- cd "$srcdir"/$_modname-nginx-module-$pkgver
- patch -p1 -i "$srcdir"/openssl-1.1.patch
-}
build() {
cd "$srcdir"/nginx-$_nginxver
./configure --with-compat --add-dynamic-module=../$_modname-nginx-module-$pkgver