summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90556464609e..534564a057cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=nginx-mainline-mod-memc
pkgver=0.18
-pkgrel=1
+pkgrel=2
_modname="${pkgname#nginx-mainline-mod-}"
-_nginxver=1.13.1
+_nginxver=1.13.3
pkgdesc='Extended version of the standard memcached module for mainline nginx'
arch=('i686' 'x86_64')
@@ -16,21 +16,14 @@ license=('BSD')
source=(
https://nginx.org/download/nginx-$_nginxver.tar.gz
https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz
- $pkgname-$pkgver-default_port.patch::https://github.com/openresty/memc-nginx-module/commit/c08cb7043440e427867838caf21cfd1e6cb2127a.patch
)
-sha256sums=('a5856c72a6609a4dc68c88a7f3c33b79e6693343b62952e021e043fe347b6776'
- '4e280d1dcb8b312bc7875604c1e35b17879279126d3d5fbf482aa9cc7c11276d'
- 'b5f9b83a0d2a08f1efc71ce8099eaa4e1d283afd502a7062ac4f150d569140ff')
-
-prepare() {
- cd "$srcdir"/$_modname-nginx-module-$pkgver
- patch -p1 -i "$srcdir"/$pkgname-$pkgver-default_port.patch
-}
+sha256sums=('5b73f98004c302fb8e4a172abf046d9ce77739a82487e4873b39f9b0dcbb0d72'
+ '4e280d1dcb8b312bc7875604c1e35b17879279126d3d5fbf482aa9cc7c11276d')
build() {
cd "$srcdir"/nginx-$_nginxver
- ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../$_modname-nginx-module-$pkgver
+ ./configure --with-compat --add-dynamic-module=../$_modname-nginx-module-$pkgver
make modules
}