summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c419958be97..782b639f0772 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Drew DeVault
pkgname=nginx-quic
-pkgver=1.19.10
-pkgrel=2
+pkgver=1.20.0
+pkgrel=1
pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, HTTP/3 QUIC branch'
arch=('i686' 'x86_64')
url='https://nginx.org'
@@ -25,8 +25,8 @@ backup=('etc/nginx/fastcgi.conf'
install=nginx.install
provides=('nginx')
conflicts=('nginx')
-source=("hg+https://hg.nginx.org/nginx-quic#revision=47a43b011dec"
- "git+https://boringssl.googlesource.com/boringssl#commit=0da75f35d51ab7fbfa8efaf71c87606ee26f5db3"
+source=("hg+https://hg.nginx.org/nginx-quic#revision=225e9f1dfe7c"
+ "git+https://boringssl.googlesource.com/boringssl#commit=68a799af7f6aed15dfeedc26e5ae43ebce873a6a"
"service"
"logrotate")
sha256sums=('SKIP'
@@ -72,6 +72,14 @@ _quic_flags=(
--with-stream_quic_module
)
+prepare() {
+ # Upstream hasn't merged the 1.20.0 update into the nginx-quic branch yet; do it manually
+ cd ${srcdir}/$pkgname
+ hg pull https://hg.nginx.org/nginx
+ hg merge 3ebf8a5fb670
+ hg commit -u aur -m "[automated aur commit] Merged with default branch"
+}
+
build() {
export CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=[1-9]/-D_FORTIFY_SOURCE=0}
export CXXFLAGS="$CXXFLAGS -fPIC"