summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 878ed0fac112..f0758408f508 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,36 @@
-# Maintainer: Rafael Cavalcanti <rccavalcanti at gmail dot com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Rafael Cavalcanti <rccavalcanti at gmail dot com>
# Contributor: Jorge Barroso <jorge.barroso.11 at gmail dot com>
# Contributor: x-demon
pkgname=nicotine-plus-git
-_gitname=nicotine-plus
-pkgver=1.4.1.r17.g8b2c199
-pkgrel=2
-pkgdesc="A fork of Nicotine, a graphical client for Soulseek."
+pkgver=1.4.1.r33.g7652f169
+pkgrel=1
+pkgdesc="A graphical client for the SoulSeek peer-to-peer system"
arch=('any')
-url="http://nicotine-plus.org/"
+url="http://nicotine-plus.org"
license=('GPL3')
-depends=('pygtk' 'gtk2' 'python2-mutagen')
+depends=('pygtk' 'python2-mutagen')
makedepends=('git' 'python2')
optdepends=('miniupnpc: UPnP support'
- 'python2-geoip: for geo-blocker'
- 'python2-notify: for notifications')
-source=(git+https://github.com/Nicotine-Plus/${_gitname}.git)
+ 'python2-geoip: for geo-blocker'
+ 'python2-notify: for notifications')
+provides=("${pkgname%-git}" 'nicotine+' 'nicotine')
+conflicts=("${pkgname%-git}" 'nicotine+' 'nicotine')
+source=("git+https://github.com/Nicotine-Plus/nicotine-plus.git")
sha512sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_gitname}"
- git describe --long --tags | sed 's/-/.r/;s/-/./'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_gitname}"
+ cd "$srcdir/${pkgname%-git}"
python2 setup.py build
}
package() {
- cd "${srcdir}/${_gitname}"
+ cd "$srcdir/${pkgname%-git}"
python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
-