summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc904ddc147d..0f0c9f9d12da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Jorge Barroso <jorge.barroso.11 at gmail dot com>
# Contributor: x-demon
pkgname=nicotine-plus-git
-pkgver=3.2.0.dev1.r5746.6bc97e2e
-pkgrel=1
+pkgver=3.2.0rc2.r6472.c6fadb13
+pkgrel=2
pkgdesc="A graphical client for the SoulSeek peer-to-peer system"
arch=('any')
url="https://nicotine-plus.github.io/nicotine-plus"
@@ -14,12 +14,15 @@ makedepends=('appstream' 'git' 'python-setuptools')
optdepends=('gspell: for spell checking in chat'
'libappindicator-gtk3: option for tray icon'
'libayatana-appindicator: option for tray icon'
- 'gtk4: test the GTK4 version')
+ 'gtk4: test the GTK4 version'
+ 'libadwaita: test the GTK4 version')
checkdepends=('appstream-glib' 'desktop-file-utils' 'python-pytest-xvfb')
provides=("${pkgname%-git}" 'nicotine+' 'nicotine')
conflicts=("${pkgname%-git}" 'nicotine+' 'nicotine')
-source=('git+https://github.com/Nicotine-Plus/nicotine-plus.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/Nicotine-Plus/nicotine-plus.git'
+ 'org.nicotine_plus.Nicotine-gtk4.desktop')
+sha256sums=('SKIP'
+ 'a9134a8afe1071f240e012105f721515cd5ad9ad538bb66a51937f06b2f04195')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -54,6 +57,9 @@ package() {
cd "$srcdir/${pkgname%-git}"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 "$srcdir/org.nicotine_plus.Nicotine-gtk4.desktop" -t \
+ "$pkgdir/usr/share/applications/"
+
# Remove duplicate GPL license
rm "$pkgdir/usr/share/doc/nicotine/COPYING"
}