summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4668890c7a55..d56aa4e60374 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgbase=ninfs-git
pkgname=(ninfs-git ninfs-gui-git)
-pkgver=1.5.r0.gaf15e6d
+pkgver=1.6.r0.gc2caa0f
pkgrel=1
pkgdesc="FUSE filesystem Python scripts for Nintendo console files"
arch=($CARCH)
license=(MIT)
url='https://github.com/ihaveamac/ninfs'
-makedepends=('python-setuptools' 'python-pycryptodomex' 'git')
+makedepends=('python-setuptools' 'git')
options=(!strip)
source=("ninfs::git+${url}.git")
sha256sums=('SKIP')
@@ -22,7 +22,7 @@ build() {
}
package_ninfs-git() {
- depends=("python>=3.6.1" "python-pycryptodomex" "fuse2" "openssl>=1.1")
+ depends=("python>=3.6.1" "python-setuptools" "python-pycryptodomex" "fuse2" "openssl>=1.1")
conflicts=("fuse-3ds-git" "fuse-3ds" "ninfs")
replaces=("fuse-3ds-git" "fuse-3ds")
provides=("fuse-3ds-git" "fuse-3ds" "ninfs=$pkgver-$pkgrel")
@@ -33,7 +33,7 @@ package_ninfs-git() {
}
package_ninfs-gui-git() {
- depends=("ninfs-git=$pkgver-$pkgrel" "python-appjar")
+ depends=("ninfs-git=$pkgver-$pkgrel" "python-setuptools" "python-appjar" "tk")
conflicts=("fuse-3ds-gui-git" "fuse-3ds-gui" "ninfs-gui")
replaces=("fuse-3ds-gui-git" "fuse-3ds-gui")
provides=("fuse-3ds-gui-git" "fuse-3ds-gui" "ninfs-gui=$pkgver-$pkgrel")