summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b152cdb7ab2e..63c564231111 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Eduardo Sánchez Muñoz
pkgname=nlohmann-json-git
_name="${pkgname%-git}"
-pkgver=3.4.0
+pkgver=3.5.0
pkgrel=1
pkgdesc='Header-only JSON library for Modern C++'
url='https://github.com/nlohmann/json'
@@ -21,15 +21,22 @@ pkgver() {
printf %s "${v//-/+}"
}
+_cmake_flags=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_INSTALL_PREFIX=/usr
+)
+
build() {
mkdir build
cd build
- cmake ../json -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake ../json "${_cmake_flags[@]}" -DBUILD_TESTING=OFF
make
}
check() {
cd build
+ cmake ../json "${_cmake_flags[@]}" -DBUILD_TESTING=ON
+ make
ctest --output-on-failure
}