summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8258f6bbad58..0deede818f79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Jamie Magee <jamie DOT magee AT gmail DOT com>
_npmname=azurite
-_npmver=2.7.0
pkgname=nodejs-azurite
-pkgver=2.7.0
+pkgver=3.30.0 # renovate: datasource=github-tags depName=Azure/Azurite
pkgrel=2
pkgdesc="A lightweight server clone of Azure Storage that simulates most of the commands supported by it with minimal dependencies"
arch=(any)
@@ -10,16 +9,17 @@ url="https://github.com/azure/azurite"
license=(MIT)
depends=('nodejs' 'npm')
optdepends=()
-source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
-noextract=($_npmname-$_npmver.tgz)
-b2sums=('71f40437f7cca9b8bf650889ab6bf3ea145d84899adb33b22cd8543dc6bb0c2827af8d0b950ef4791e8bdc72c65d1cb5eda7248b70cca5ae2656b7c6490809d0')
+source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+b2sums=('77eb276be931617c16d421e16e40c9ab6ba513dbd7f45642596733c3ad8f481707610deac2ea2879b5b1c50b5bb2a0a32baeaafe9c25d42714b4c867fabf20a5')
+options=('!strip')
package() {
cd "$srcdir"
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p "$_npmdir"
cd "$_npmdir"
- npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+ npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
# Non-deterministic race in npm gives 777 permissions to random directories.
# See https://github.com/npm/npm/issues/9359 for details.
find "${pkgdir}"/usr -type d -exec chmod 755 {} +