summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..623f021e536b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=nodejs-fauna-shell
+_pkgname=${pkgname#nodejs-}
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="faunadb access via the cli"
+arch=(any)
+url="https://github.com/fauna/fauna-shell"
+licence=(MPL2)
+depends=(nodejs)
+makedepends=(npm)
+source=("https://registry.npmjs.org/$_pkgname/_/$_pkgname-$pkgver.tgz")
+sha256sums=('e587255300cfd8e8be5afa5d9497bdb612eeeca5e165d65bd05fbd2e041ec840')
+noextract=("$_pkgname-$pkgver.tgz")
+
+package() {
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir"/"$_pkgname-$pkgver.tgz"
+ find "$pkgdir"/usr -type d -exec chmod 755 {} +
+}