summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ae0fe3f521d..92a7b02956c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,12 @@
_npmname=how2
pkgname=nodejs-how2
pkgver=1.1.0
-pkgrel=2
-pkgdesc="how2 finds the simplest way to do something in a unix shell. It's like man, but you can query it in natural language:"
+pkgrel=3
+pkgdesc="finds the simplest way to do something in a unix shell. It's like man, but you can query it in natural language:"
arch=(any)
url="https://github.com/santinic/how2"
license=(MIT)
depends=('nodejs' 'npm')
-optdepends=()
source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
noextract=($_npmname-$pkgver.tgz)
sha256sums=('96adf72bfa307c5413314afb547179e781f9ef18db6c7233b104da399657478e')
@@ -19,6 +18,6 @@ package() {
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p "$_npmdir"
cd "$_npmdir"
- npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ npm install -g --prefix "$pkgdir/usr" "$srcdir/$_npmname-$pkgver.tgz"
+ install -Dm644 "how2/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}