summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..757fb4527f31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+_npmname=json-diff
+pkgname=nodejs-json-diff # All lowercase
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="JSON diff"
+arch=(any)
+url="https://github.com/andreyvit/json-diff"
+license=()
+depends=('nodejs' 'npm')
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+sha1sums=('6dbc3ae2d25e075a7fd71bcd9874458666fb681b')
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+}
+# vim:set ts=2 sw=2 et: