summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d4b726d9f42..257ed0e44d61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
-_npmname=npm2arch
-_npmver=0.1.19
+_npmname=@simon04/npm2arch
+_npmver=1.0.0
pkgname=nodejs-npm2arch # All lowercase
-pkgver=0.1.19
-pkgrel=2
+pkgver=1.0.0
+pkgrel=1
pkgdesc="Convert NPM package to a PKGBUILD for ArchLinux"
arch=(any)
-url="https://github.com/Filirom1/npm2arch"
+url="https://github.com/simon04/npm2arch"
license=(MIT)
-depends=('nodejs' 'npm' )
+depends=('nodejs' 'npm')
optdepends=()
-source=(git+http://github.com/MazeChaZer/npm2arch.git#branch=feature/upgrade-dependencies)
+source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
noextract=($_npmname-$_npmver.tgz)
-sha1sums=(SKIP)
+sha1sums=(e53348f74f661b3430f94011a3d597fb0db80741)
package() {
- cd "$srcdir/$_npmname"
+ cd $srcdir
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p $_npmdir
- npm install -g --prefix "$pkgdir/usr"
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+ sed -i '/"_where":/d' "$_npmname/package.json"
}
# vim:set ts=2 sw=2 et: