summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbf973296e01..5eb3325201e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=nomad
-pkgver=0.6.2
+pkgver=0.6.3
pkgrel=1
pkgdesc="A Distributed, Highly Available, Datacenter-Aware Scheduler"
arch=('i686' 'x86_64')
url="https://www.nomadproject.io/"
license=('MPL')
-depends=('ethtool')
+depends=('ethtool' 'lxc')
makedepends=('go' 'git')
optdepends=(
'docker'
@@ -17,7 +17,7 @@ optdepends=(
backup=(etc/nomad/{server,client}.conf)
source=(https://github.com/hashicorp/nomad/archive/v$pkgver/$pkgname-$pkgver.tar.gz
nomad-{server,client}.{service,conf})
-sha256sums=('091d95e744f99139f4b4f2ca61394b45aa44cb7ee45f62958614767e43f61158'
+sha256sums=('b24b4960b8a5e5a11885dc763d05adb25c05a4f939c2492ec181984caf9755a8'
'52b0a22c3c0c72c642a8728cb48bd8797f4f6a12990e11bbb2342edcc2a9a206'
'da475bc4aa3b1493eb62f09e7f99dcc171e8ce6d74df3da30514cfdfe72a5714'
'4c8fb7c18c67ca20e3ee07f25cf2f0c82b66c4c173275ae8d643c91cce3c0ceb'
@@ -28,18 +28,12 @@ prepare() {
cd src/github.com/hashicorp
rm -rf nomad
mv ../../../$pkgname-$pkgver nomad
- cd nomad
-
- sed -r -e 's/^GIT_COMMIT=.*/GIT_COMMIT=-/' \
- -e 's/^GIT_DIRTY=.*/GIT_DIRTY=""/' \
- -i scripts/build.sh
}
build() {
cd src/github.com/hashicorp/nomad
export GOPATH="$srcdir"
export PATH="$GOPATH/bin:$PATH"
- export NOMAD_DEV=1
if [ $CARCH == "x86_64" ]; then
export GOARCH=amd64
@@ -49,7 +43,10 @@ build() {
make bootstrap
mkdir -p bin
- CGO_ENABLED=1 go build -o bin/nomad
+ CGO_ENABLED=1 \
+ go build -ldflags '-X main.GitCommit=""' \
+ -tags lxc \
+ -o bin/nomad
}
package() {