summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c301f1c7b583
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: thek4n
+
+pkgname='note-manager'
+pkgver=1.15.0
+pkgrel=1
+pkgdesc="Simple CLI notes manager"
+arch=('any')
+url='https://github.com/thek4n/note'
+license=('MIT')
+depends=(
+ 'git'
+)
+optdepends=(
+ 'python-grip: render tips in browser'
+ 'fzf: find notes'
+ 'bat: render tips in terminal'
+ 'tree: tree of notes'
+)
+conflicts=('note-manager')
+source=("$pkgname::git+https://github.com/thek4n/note.git#branch=master")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir"/"$pkgname"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}