summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c479ebdb012..00cf388d10e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Jaime Martínez Rincón <jaime@jamezrin.name>
+
pkgname=notion-app
pkgver=2.0.16
-pkgrel=7
+pkgrel=8
epoch=2
pkgdesc="The all-in-one workspace for your notes and tasks"
arch=('i686' 'x86_64')
@@ -9,13 +10,10 @@ url="https://www.notion.so/desktop"
license=('MIT')
depends=('re2' 'gtk3' 'xdg-utils')
makedepends=('imagemagick' 'p7zip' 'npm' 'nodejs>=14' 'python2')
-optdepends=('notion-enhancer: enhancements and fixes')
source=("Notion-"${pkgver}".exe::https://desktop-release.notion-static.com/Notion%20Setup%20${pkgver}.exe"
- 'notion-app.desktop'
- 'exit-after-windows-closed.patch')
+ 'notion-app.desktop')
md5sums=('9f72284086cda3977f7f569dff3974d5'
- '257f3106e5d9364ef2df557a656cd8e7'
- 'aaa50ed0208c4d6d31f553fd3bd46b1c')
+ '257f3106e5d9364ef2df557a656cd8e7')
build() {
msg "Extracting app from Windows build..."
7z x -y "${srcdir}/Notion-"${pkgver}".exe" -o"${srcdir}/extracted-exe" >/dev/null
@@ -30,8 +28,8 @@ build() {
cd "${srcdir}/package-rebuild"
msg "Patching original sources for fixes..."
- patch -p1 --binary --ignore-whitespace < "${srcdir}/exit-after-windows-closed.patch"
-
+ sed -i 's|process.platform === "win32"|process.platform !== "darwin"|g' main/main.js
+
msg "Recreating package node_modules..."
rm -r node_modules
npm install --cache "${srcdir}/npm-cache"
@@ -58,7 +56,5 @@ package() {
install -Dm644 "${srcdir}/package-rebuild/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications"
ln -s "/opt/${pkgname}/notion" "${pkgdir}/usr/bin/${pkgname}"
-
- # for compatibility with notion-enhancer
- ln -s "/opt/${pkgname}/resources/app.asar" "${pkgdir}/opt/${pkgname}/app.asar"
}
+