summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 24 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3f8429ecb6d..9c4117df2b81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,39 @@
-# $Id: PKGBUILD 249884 2015-10-30 21:49:02Z arojas $
-# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Claire Charron <claire@undeterminant.net>
-
+# shellcheck shell=bash disable=SC2034,SC2164
_pkgname=noto-fonts-emoji
pkgname=$_pkgname-git
-pkgver=r81.9417128
-pkgrel=3
-pkgdesc="Google Noto emoji fonts"
-arch=(any)
-url="https://www.google.com/get/noto/"
-license=(Apache)
-provides=($_pkgname)
-conflicts=($_pkgname)
-depends=(fontconfig)
-makedepends=(cairo git optipng python2-fonttools python2-setuptools nototools zopflipng-git)
-install=$_pkgname.install
-source=("$_pkgname::git+https://github.com/googlei18n/noto-emoji.git"
- "$_pkgname.patch")
-sha512sums=('SKIP'
- '72f3c82ba3a1e69c158c3238c4c817df3e77302071ec1094fb284863ee72fb00117d89531ba75412501507984df4561ad013a09ac5742728c240bf073d80f4d0')
+pkgver=2020.04.08.unicode12_1.r23.g8990ed0f
+pkgrel=1
+epoch=1
+pkgdesc="Noto Emoji fonts"
+arch=('any')
+url="https://github.com/googlefonts/noto-emoji"
+license=('Apache')
+makedepends=('git' 'zopfli' 'python-fonttools' 'python-nototools' 'pngquant' 'cairo' 'imagemagick')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git")
+md5sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$_pkgname"
- patch -i ../$_pkgname.patch
- find -name '*.py' | xargs sed -e 's|/usr/bin/env python|/usr/bin/env python2|' -i
- sed -e 's|python|python2|g' -e 's|ttx "$<"|ttx2 "$<"|g' -i Makefile
+ cd $_pkgname
+ make clean
}
build() {
- cd "$_pkgname"
- make
+ cd $_pkgname
+ make VIRTUAL_ENV=dummy
}
package() {
- cd "$_pkgname"
- mkdir -p "$pkgdir"/usr/share/fonts/noto
- install -m644 NotoColorEmoji.ttf fonts/NotoEmoji-Regular.ttf "$pkgdir"/usr/share/fonts/noto
+ cd $_pkgname
+ # shellcheck disable=SC2154
+ install -Dm644 -t "$pkgdir"/usr/share/fonts/noto NotoColorEmoji.ttf
}