summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38f270867199..1136cb7ca01f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-# Maintainer: Martin Peres <martin.peres[at]free[dot]fr>
+# Maintainer: Boris Yumankulov <boriabloger[at]protonmail[dot]com>
+# Contributor: Martin Peres <martin.peres[at]free[dot]fr>
# Contributor: Timothée Ravier <tim[at]siosm[dot]fr>
pkgname=nouveau-fw
-pkgver=325.15
+pkgver=340.108
pkgrel=1
pkgdesc="This package provides video & pgraph firmwares for all NVIDIA chipsets that need them"
url='http://nouveau.freedesktop.org/wiki/'
arch=('any')
license=('custom')
-makedepends=('python2')
-source=("https://raw.github.com/imirkin/re-vp2/master/extract_firmware.py"
- "http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
+makedepends=('python3')
+source=("https://raw.githubusercontent.com/envytools/firmware/master/extract_firmware.py"
+"http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}.run")
md5sums=('SKIP'
- '528fc538584de6446384b9cec3099d6c')
+ 'SKIP')
sha256sums=('SKIP'
- '3d790e4bfed24641f7cc76879144ab5d52b12271012ba381b0d33aa1a2e08775')
+ 'SKIP')
build() {
- sh NVIDIA-Linux-x86-${pkgver}.run --extract-only
- python2 extract_firmware.py
+ sh NVIDIA-Linux-x86_64-${pkgver}.run --extract-only
+ python3 extract_firmware.py
}
package() {